Sysmo DB
  1. Sysmo DB
  2. SYSMO-1490

Navigation problems in SEEk if using back button of the browser

    Details

    • Type: Improvement Improvement
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.20
    • Environment:
      software

      Description

      Very often I work in SEEK starting navigation from project page to associated assets - to assay or data file or any other tab of projectasociated assets - and 1. see the short list of them first, so 2. I click "show all" button and 3. go to any one to get details page. WORKS well till now.
      PROBLEM appears if I want to 4. go back to the whole list of assays or data filesI came from - I only can use back-button of the browser (there is no "back to the list of data files" option there) , BUT !!!! 5. I never get to that list I always get the starting page of the project with default list of persons instead. So if I have to check/read/edit 20 data file pages, I have to repeat steps 1-5 20 times This is very annoying and time consuming. Quyen and Mike told me that this appears because of the REST API , but I don't know detailed reason

        Activity

        Stuart Owen added a comment -

        Its nothing to do with the REST API.
        The problem is caused by a recent change where when selecting show all, and AJAX request is made to fetch the list, and populates the segment of the current page with the new list. No new page loaded , so after following a link the browser goes back to the original page without the dynamically updated segment.
        Along with other problems, I agree with Olga that the behaviour is not desirable, so I'd like this to be put back to how it previously was, without the AJAX and with a proper dedicated routes. Along with solving Olga problem it also would provide benefits of being able to filter over the list and also provide explicit routes for this too - such as .../projects/2/data_files or .../people/22/models - which is something that has been requested.


          People

          • Assignee:
            Stuart Owen
            Reporter:
            Olga Krebs
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: