Sysmo DB
  1. Sysmo DB
  2. SYSMO-154

Registration for non-sysmo user assigns incorrect profile

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.4.1
    • Fix Version/s: 0.4.2
    • Labels:
      None

      Description

      When registerting you can fill out details for a profile. After registration you get redirected to a page that shows that profile but when you then go to edit profile the profile is blank. Looking at the database it appears that the profile you fill in isn't assigned to the registered user, but a new one is created.

      May be affected by having activation turned off - needs testing with both.

      This could do with an integration test.

        Issue Links

          Activity

          Stuart Owen added a comment -

          Fixed and tested with both activation on and off. Was caused by a person being assigned when the user is created. This has now been removed.


            People

            • Assignee:
              Stuart Owen
              Reporter:
              Stuart Owen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 3 hours
                3h
                Remaining:
                Remaining Estimate - 3 hours
                3h
                Logged:
                Time Spent - Not Specified
                Not Specified