myGrid
  1. myGrid
  2. TAV-344

Beanshell port adding don't update "Configure beanshell" dialogue

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 1.5.1
    • Labels:
      None
    • Environment:
      Mac OS X 10.4, Java 1.5.0_06

      Description

      Add a new "Beanshell scripting host" to a blank workflow. Right click on it and do Configure.

      Go to Ports. Add an input named fish, click the "Add input" button or press Enter. Nothing happens in the dialogue window, but in the workbench "fish" appears as a possible input to the processor. Resize the dialouge window or switch between "Script" and "Ports", and the new port will appear. Seems like some kind of redraw/invalidate problem, should be easy to fix.

        Activity

        Hide
        June Finch (Inactive) added a comment -

        This appears easy to fix in time for the 1.5.1 release.

        Show
        June Finch (Inactive) added a comment - This appears easy to fix in time for the 1.5.1 release.
        Hide
        Stian Soiland-Reyes added a comment -

        Added some revalidate() and repaint() here and there.. also applied to the BSF processor, which seems to be copy-and-paste code.

        Show
        Stian Soiland-Reyes added a comment - Added some revalidate() and repaint() here and there.. also applied to the BSF processor, which seems to be copy-and-paste code.

          People

          • Assignee:
            Stian Soiland-Reyes
            Reporter:
            Stian Soiland-Reyes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: