myGrid
  1. myGrid
  2. TAV-553

Fetching results unpredictable

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.7.1
    • Labels:
      None

      Description

      When clicking on the job in the Taverna plugin, occasionally the results don't appear propertly, but stops half way through and only displays the status. As if the workflow was still running when it is actually complete.

        Activity

        Hide
        June Finch (Inactive) added a comment -

        Monitor for direct feedback from users on this. Can't justify effort in investigation on this at the moment unless that happens.

        Show
        June Finch (Inactive) added a comment - Monitor for direct feedback from users on this. Can't justify effort in investigation on this at the moment unless that happens.
        Hide
        Stuart Owen added a comment -

        The original manifestation of this bug is now fixed, but it still appears in a slightly different scenario.
        If a workflow is complete and you click "View Results" the results now always appear, however if a workflow is in progress and you are monitoring its progress then the final results don't appear when the workflow is finished. You need to close Taverna and click View Results to see the final results.

        Show
        Stuart Owen added a comment - The original manifestation of this bug is now fixed, but it still appears in a slightly different scenario. If a workflow is complete and you click "View Results" the results now always appear, however if a workflow is in progress and you are monitoring its progress then the final results don't appear when the workflow is finished. You need to close Taverna and click View Results to see the final results.
        Hide
        Stuart Owen added a comment -

        This is now fixed. It was caused by the results not properly being recorded because of the stream being cut off. It was actually fixed a while ago, and a new enactment service was released once solved.

        Show
        Stuart Owen added a comment - This is now fixed. It was caused by the results not properly being recorded because of the stream being cut off. It was actually fixed a while ago, and a new enactment service was released once solved.

          People

          • Assignee:
            Stuart Owen
            Reporter:
            Stuart Owen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: