myGrid
  1. myGrid
  2. TAV-694

t2: Conditionals fire even on errors

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: By Design
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: None
    • Labels:
      None

      Description

      The Conditional Branching example does not work, because both constants fire, and one of them is picked by semi-random as the result.

      The reason is that the conditional fireing still fires even on an error. A dummy workflow with a string constants "Coordinated from" a beanshell script that does Thread.sleep(5000), shows that coordination works in principle.

      However, if the beanshell is changed to throw an Exception, the string constant will still be produced.

        Activity

        Tom Oinn added a comment -

        This is correct behaviour in T2 in terms of existing code. This is because errors at the moment get turned into error tokens and passed out in the data stream, the stream completes so the condition is satisfied. We need to implement the workflow / orchestration level failure mode but this particular behaviour is not a bug.


          People

          • Assignee:
            Tom Oinn
            Reporter:
            Stian Soiland-Reyes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: