myGrid
  1. myGrid
  2. TAV-706

T2 XMLInputSplitterActivity problem

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: None
    • Labels:
      None

      Description

      When running the attached workflow (Phenotype to pubmed - provided by Paul, bear in mind it takes a while to load) with the input "african trypanosomiasis AND mouse" then the following error occurs:

      ERROR 2008-01-11 10:20:54,325 net.sf.taverna.t2.workflowmodel.processor.dispatch.impl.DispatchStackImpl (DispatchStackImpl$1:156) Error received in dispatch stack on owningProcess:facade0:dataflow2:parametersXML_eSearch, msg:Error in XMLInputSplitterActivity
      java.lang.IllegalStateException: Invalid directory/Users/sowen/Library/Application Support/Taverna-1.7.0/t2-datamanager/a34b5427-25a8-4039-b471-ffe69a6aa16a/blob/fa
      at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.parentDirectory(FileBlobStore.java:317)
      at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.fileById(FileBlobStore.java:285)
      at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.storeFromStream(FileBlobStore.java:245)
      at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.storeFromString(FileBlobStore.java:276)
      at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:260)
      at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:151)
      at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:103)
      at net.sf.taverna.t2.activities.wsdl.xmlsplitter.XMLInputSplitterActivity$1.createOutputData(XMLInputSplitterActivity.java:81)
      at net.sf.taverna.t2.activities.wsdl.xmlsplitter.XMLInputSplitterActivity$1.run(XMLInputSplitterActivity.java:69)
      at java.lang.Thread.run(Thread.java:613)

      i.e. there is a problem with the splitter at the top of the workflow.
      The workflow passes all health checks, and runs successfully with the T1 enactor.

      1. e_Search_Test.xml
        5 kB
        Stuart Owen
      2. pauls_workflow.xml
        10 kB
        Stuart Owen
      3. pauls_workflow-inner.xml
        5 kB
        Stuart Owen
      4. phenotype_to_pubmed.xml
        10 kB
        Stuart Owen

        Activity

        Stuart Owen added a comment -

        an example input is "african trypanosomiasis AND mouse" (without the quotes)

        Stuart Owen made changes -
        Field Original Value New Value
        Attachment phenotype_to_pubmed.xml [ 10093 ]
        Stuart Owen added a comment -

        I've also attached a workflow that contains just the call to esearch, plus the upstream splitter fed with string constants just as in Pauls workflow. However, this works.

        Stuart Owen made changes -
        Attachment e_Search_Test.xml [ 10094 ]
        Stuart Owen made changes -
        Description When running the attached workflow (provided by Paul, bear in mind it takes a while to load) with the input "african trypanosomiasis AND mouse" then the following error occurs:

        ERROR 2008-01-11 10:20:54,325 net.sf.taverna.t2.workflowmodel.processor.dispatch.impl.DispatchStackImpl (DispatchStackImpl$1:156) Error received in dispatch stack on owningProcess:facade0:dataflow2:parametersXML_eSearch, msg:Error in XMLInputSplitterActivity
        java.lang.IllegalStateException: Invalid directory/Users/sowen/Library/Application Support/Taverna-1.7.0/t2-datamanager/a34b5427-25a8-4039-b471-ffe69a6aa16a/blob/fa
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.parentDirectory(FileBlobStore.java:317)
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.fileById(FileBlobStore.java:285)
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.storeFromStream(FileBlobStore.java:245)
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.storeFromString(FileBlobStore.java:276)
                at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:260)
                at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:151)
                at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:103)
                at net.sf.taverna.t2.activities.wsdl.xmlsplitter.XMLInputSplitterActivity$1.createOutputData(XMLInputSplitterActivity.java:81)
                at net.sf.taverna.t2.activities.wsdl.xmlsplitter.XMLInputSplitterActivity$1.run(XMLInputSplitterActivity.java:69)
                at java.lang.Thread.run(Thread.java:613)

        i.e. there is a problem with the splitter at the top of the workflow.
        The workflow passes all health checks, and runs successfully with the T1 enactor.
        When running the attached workflow (Phenotype to pubmed - provided by Paul, bear in mind it takes a while to load) with the input "african trypanosomiasis AND mouse" then the following error occurs:

        ERROR 2008-01-11 10:20:54,325 net.sf.taverna.t2.workflowmodel.processor.dispatch.impl.DispatchStackImpl (DispatchStackImpl$1:156) Error received in dispatch stack on owningProcess:facade0:dataflow2:parametersXML_eSearch, msg:Error in XMLInputSplitterActivity
        java.lang.IllegalStateException: Invalid directory/Users/sowen/Library/Application Support/Taverna-1.7.0/t2-datamanager/a34b5427-25a8-4039-b471-ffe69a6aa16a/blob/fa
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.parentDirectory(FileBlobStore.java:317)
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.fileById(FileBlobStore.java:285)
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.storeFromStream(FileBlobStore.java:245)
                at net.sf.taverna.t2.cloudone.datamanager.file.FileBlobStore.storeFromString(FileBlobStore.java:276)
                at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:260)
                at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:151)
                at net.sf.taverna.t2.cloudone.datamanager.DataFacade.register(DataFacade.java:103)
                at net.sf.taverna.t2.activities.wsdl.xmlsplitter.XMLInputSplitterActivity$1.createOutputData(XMLInputSplitterActivity.java:81)
                at net.sf.taverna.t2.activities.wsdl.xmlsplitter.XMLInputSplitterActivity$1.run(XMLInputSplitterActivity.java:69)
                at java.lang.Thread.run(Thread.java:613)

        i.e. there is a problem with the splitter at the top of the workflow.
        The workflow passes all health checks, and runs successfully with the T1 enactor.
        Alan Williams added a comment -

        I think this comes under session management

        Alan Williams made changes -
        Assignee Alan Williams [ awilliams ] David Withers [ witherd5 ]
        Stuart Owen added a comment -

        It seems resaving the workflow to create the attached workflow (to overcome path issues with pauls nested workflows) fixes the above problem. However, the workflow still doesn't complete for other reasons - yet to be determined.

        The problem reported here still remains an issue though and I'll attach the original workflows. The outer workflow is pauls_workflow.xml and the inner nested workflow is pauls_workflow-inner.xml . The outer workflow scufl will need editing to correct the path to the inner workflow, which is currently set to:

        <s:workflow>
        <s:xscufllocation>file:/Users/sowen/tmp/pauls_workflow-inner.xml</s:xscufllocation>
        </s:workflow>

        Stuart Owen made changes -
        Attachment pauls_workflow.xml [ 10095 ]
        Stuart Owen made changes -
        Attachment pauls_workflow-inner.xml [ 10096 ]
        Stuart Owen added a comment -

        Closing this as its not a bug specific to the XML splitter. It seems to be a general enactment/error handling error.

        Stuart Owen made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee David Withers [ witherd5 ] Alan Williams [ awilliams ]
        Resolution Not A Bug [ 6 ]

        Error rendering 'com.atlassian.jira.plugins.jira-bitbucket-connector-plugin:dvcs-commits-tabpanel'. Please contact your JIRA administrators.

          People

          • Assignee:
            Alan Williams
            Reporter:
            Stuart Owen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: