Skip to end of metadata
Go to start of metadata

See the documentation.

Build, Run and Reuse Workflows

Video (needs voiceover + captions):

http://dl.dropbox.com/u/4958764/docathon/quickStartFull.mp4

This video shows how to build and run a simple workflow and reuse existing workflows from myExperiment.

We will start with a simple workflow. Search for "Get_protein_fasta" in the list of Available services in Service Panel and drag it into the Workflow Diagram. Add a workflow input (e.g. called "ID") by right-clicking and selecting Insert -> Workflow input port. Repeat with a workflow output port (call it "Sequence").

Connect ID to Get_Protein_Fasta by drag and drop from ID. Repeat to connect sequence (the workflow output).

You can import other Web services into Taverna by providing the WSDL URL. Here we will add the DDBJ Blast service. New services will appear in the list of Available services in the Service Panel.

Add the new "SearchSimple" service to your workflow by drag-and-dropping it to the Workflow Diagram. Connect "Get_Protein_Fasta" and "SearchSimple" via the "query" port. The other two ports can be defined as constant values in this case. Add a constant value "SWISS" to database and "blastp" to program. Add a workflow output for "SearchSimple".

You can also add annotations to you workflow - description of what the workflow does and author details. These are useful for other people reusing your workflows.

We will now run the workflow by selecting Run workflow... from the File menu. In the dialog that pops-up, add a GI number as input data. As the workflow runs, you can see its progress in the Result Perspective. This workflow returns a protein sequence and a Blast result.

Now we will combine this workflow with another from myExperiment. You can log in to myExperiment from the myExperiment Perspective, or browse as a guest. The Starter Pack tab provides some example workflows. You can also search myExperiment by tag or keyword, e.g. "KEGG".

Import the "NCBI GI to KEGG Pathway" workflow. Taverna will ask if you want to merge or add as a nested workflow to your current workflow. We will add it as a nested workflow to keep it as a separate workflow module. Connect the nested workflow to the main workflow and validate the workflow before running to look for any potential problems. Taverna can report errors in workflow construction and potential problems with services.

Run the modified workflow now.  As the workflow runs, you can see its progress. You can view the results at the bottom of the Results Perspective. You can investigate intermediate results by clicking on services in the Graph or Table tabs of the Progress Report.

Open Workflows from URLs

Video (needs voiceover + captions):

http://dl.dropbox.com/u/3262735/from_myexp_to_taverna_open_url.mp4

This video showcases the ability of the Taverna Workbench to open workflows from URLs.

We will use the myExperiment workflow repository to obtain a suitable workflow. Navigating to the myExperiment Web site, we are presented with a page where we can browse for content, register, or log in. As we simply require a workflow, we can enter a search term (e.g. "QTL") into the search box, and then select "workflow" from the neighbouring drop-down menu. Hitting the Enter key will direct you to a list of available workflows that match or contain the search term. Choosing one of these entries (by clicking on the title or "view" button) will direct you to the entry for that workflow.

Each workflow on myExperiment has a unique id so that it may be referenced in publications or linked to via remote resources - in this case Taverna. You can identify the workflow id at the end of the URL. An example of this is given as: http://www.myexperiment.org/workflows/16.html. This URL, however, should not be used when loading a workflow via URL. This is due the to the fact that the Taverna Workbench does not know which version of the workflow to use. Each workflow may have multiple versions as it is repaired, improved, or refined. As a consequence, a separate URL is present within each myExperiment workflow entry. This can be found lower down in the workflow entry, under the Run sub-heading. Here you will be able to find Option 2 to "Copy and paste this link into File > 'Open workflow location...'". Simply right click on this URL, choose "Copy file location", or highlight the URL text and use the "Edit->Copy/Paste" menu options. This will then be used to identify the correct version of the workflow to use. If necessary, you can opt to use older version of the workflow should your needs change.

Once you have the Taverna Workbench running, simply navigate to the File menu, and choose the "Open workflow location.." option. This will present you with a pop-up box in which to enter/paste the URL of the workflow you wish to open. Enter/paste your URL into this box and then click the OK button. The workflow will then be opened within your Taverna Workbench. Note, however, that certain permissions on the myExperiment Web site may restrict your access, and will result in an error message in Taverna. Please check you have suitable permissions on myExperiment to be able open this workflow.

View Workflow Provenance and Intermediate Results

Video (needs voiceover + captions + text):

http://dl.dropbox.com/u/3262735/how_to_use_provenance.mp4

Labels
  • None