Skip to end of metadata
Go to start of metadata

Watch the Quick start video.

The Taverna Workbench is a powerful scientific workflow management application that allows designing and executing workflows. Scientific workflows help tackle the problem of excessive complexity of in silico experimentation  by helping scientists model what an experiment is set to achieve, while abstracting out how it will be executed. This quick start guide will help you open, create and run a workflow.

Before you start, you should download the Taverna Workbench.

Opening an Existing Workflow

It is simple to open an existing workflow inside the Taverna Workbench.

1.a If you do not have an existing workflow, you can download and open one from the Sample Pack tab in the myExperiment Perspective of the Workbench.
1.b Alternatively, you can also download one from the myExperiment Web site (or anywhere else on the Web) by selecting Open workflow location... from the File menu and entering the workflow's URL.
1.c Finally, you can select Open workflow from the File menu. You will be presented with a file chooser dialog, the exact appearance of which will be determined by your operating system. In this demonstration, choose the workflow you downloaded.

If the workflow loads correctly, the Workflow Diagram and Workflow Explorer are populated with the workflow defined in the file. There may be a short delay while Taverna contacts the network to get more information about the resources (services) the workflow uses – if the delay is a very long one followed by an error you probably need to check the configuration of your HTTP proxy preferences.

Creating a Workflow

We will now create and run a very simple workflow to list some cities in a country. When you start the Workbench up, the default perspective you are presented with is the Design Perspective, which is used for creating and editing workflows.

To start creating a new workflow:

  1. Select New workflow from the File menu.
  2. Alternatively, if you have just started the Taverna Workbench, you will have a new blank workflow opened by default. You can start editing it.

Adding a service into Taverna

Taverna does not, by default, know about a suitable service to perform the desired functionality. Thus, you have to add such a service to your workflow.

To add a new Web service (i.e. WSDL service):

  1. Click Import new services in the Service Panel and then WSDL service…
  2. Enter the URL of the WSDL, in this case http://www.webservicex.com/globalweather.asmx?WSDL and click OK.

After a while, the service will become available in the Service Panel. If you filter the services by "globalweather" then you can see the two new services under:

Adding a service into the workflow

To add a service we have just imported in Taverna into the workflow:

  1. Click on GetCitiesByCountry in the Service Panel and drag it into the Workflow Diagram or to the tree in the Workflow Explorer.

Creating the workflow inputs

The workflow needs to have an input, in this case the name of the country to query. You can create a new workflow input if you:

  1. Right-click in a blank area of the Workflow Diagram and select Workflow input port from the Insert menu.
  2. You will be prompted for a name for the input port. You can change this later but for now use "country".
  3. Your new input appear in the Workflow Diagram and Workflow Explorer.

Similarly, the workflow will need an output. Follow an equivalent process but this time clicking on Workflow output port from the Insert menu and using the name "cities" to create an output. Again, you should see the output appear in the Workflow Diagram and Explorer.

Splitting the WSDL inputs and outputs

For many services, you can connect their inputs and outputs directly. However, for WSDL Web services you may need to assemble or split the XML input or output value in order to extract useful information. To do this:

  1. Right-click on the service GetCitiesByCountry in the Workflow Diagram or Workflow Explorer and select Show details.
  2. A description of the activity will appear in the Details View of the Workflow Explorer.
  3. Scroll down and click both Add input XML splitter and Add output XML splitter, choosing “parameters” from the pop-up box in both cases.

Connecting everything together

To link the workflow input port to the input port of the service:

  1. Click on the “country” input port in the Workflow Diagram and, holding you mouse button, drag to the “GetCitiesByCountry_input”.
  2. A connection arrow will appear in the Workflow Diagram. If there had been several ports that you could have connected to, then the multiple options would have been offered to you.
  3. Alternatively, you may right-click the “GetCitiesByCountry_input” input port of the service and select Connect with output from… -> Workflow input ports and then select the “country” workflow input port.

To link the output port of the service to the workflow output port:

  1. Click on the “GetCitiesByCountry_output” output port of the service and drag (holding your mouse button pressed) towards the workflow output port “cities”.
  2. Alternatively, right-click on “GetCitiesByCountry_output” and select Connect as input to… -> Workflow output ports and then select the “cities” output port.

Running the Workflow

You can now run the workflow you have just created. To do so:

  1. Select Run workflow from the File menu.
  2. In the Run workflow dialog, as there is only one input port, you can click New value button. 
  3. Replace the string “Some input data goes here” by your chosen country name.
  4. After you have entered it, click the Run workflow button.

Taverna will automatically switch to the Result Perspective. The workflow run will be displayed in the Progress Monitor tabs (either as a graph showing progress or as a progress table). It shows the progress of the workflow – running services are shown green and completed ones in grey. As the results are produced they are listed, for each output, in the bottom part of the panel. After the workflow has run (indicated by GetCitiesByCountry turning grey), you will see a string "Value 1" appear in the lower left panel. This is the identifier of the output result. If you click on this, you will see the output appear rendered on the left hand side of the result panel.

Congratulations, you have created and run a workflow.

Closing the Workflow

To close the current workflow:

  1. Select Close workflow from the File menu.

Labels
  • None